Back to overview
Degraded
Reservation Engine Error
May 03 at 03:38pm PDT
Affected services
Streamline
Resolved
May 03 at 03:55pm PDT
Everything has been resolved
Affected services
Created
May 03 at 03:38pm PDT
What happened today
- IT merged a HotFix ticket to product at approximately 11:20 am
- Shortly after it was reported that a Error 500 was being recieved when trying to create a reservation.
- IT was alerted to the situation and begain investigating.
- The issue was found and the code to fix it was put into place.
- At approximately 12:30 pm the fix was merged to production.
Why this happened
- We have specific steps that should be followed before any development task is merged to production. In this case, some of the steps for testing were missed.
Estimated costs
- The situation lasted approximately ~1 hour and 30 minutes.
- All clients were affected.
How to prevent this in the future
- We are putting into place a verification process to make sure that each step of our process is strictly followed. We believe that adherence to each step in this case, would have caught the error prior to the functionality being released.
Affected services